use strict;
my $str = 'Lek
؋
$
ƒ
$
₼
$
$
Br
BZ$
$
$b
KM
P
лв
R$
$
៛
$
$
$
¥
$
₡
kn
₱
Kč
kr
RD$
$
£
$
€
£
$
¢
£
Q
£
$
L
$
Ft
kr
Rp
﷼
£
₪
J$
¥
£
лв
₩
₩
лв
₭
£
$
ден
RM
₨
$
₮
MT
$
₨
ƒ
$
C$
₦
kr
﷼
₨
B/.
Gs
S/.
₱
zł
﷼
lei
₽
£
﷼
Дин.
₨
$
$
S
R
₨
kr
CHF
$
£
NT$
฿
TT$
$
₴
£
$
$U
лв
Bs
₫
﷼
Z$
';
my $regex = qr~\b(?:[BS]/\.|R(?:D?\$|p))|
\b(?:[TN]T|[CJZ])\$|Дин\.|
\b(?:Bs|Ft|Gs|K[Mč]|Lek|B[Zr]|k[nr]|[PQLSR]|лв|ден|RM|MT|lei|zł|USD|GBP|EUR|JPY|CHF|SEK|DKK|NOK|SGD|HKD|AUD|TWD|NZD|CNY|KRW|INR|CAD|VEF|EGP|THB|IDR|PKR|MYR|PHP|MXN|VND|CZK|HUF|PLN|TRY|ZAR|ILS|ARS|CLP|BRL|RUB|QAR|AED|COP|PEN|CNH|KWD|SAR)\b|
\$[Ub]|
[\p{Sc}ƒ]~muxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}