# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
\b(?:[BS]/\.|R(?:D?\$|p))|
\b(?:[TN]T|[CJZ])\$|Дин\.|
\b(?:Bs|Ft|Gs|K[Mč]|Lek|B[Zr]|k[nr]|[PQLSR]|лв|ден|RM|MT|lei|zł|USD|GBP|EUR|JPY|CHF|SEK|DKK|NOK|SGD|HKD|AUD|TWD|NZD|CNY|KRW|INR|CAD|VEF|EGP|THB|IDR|PKR|MYR|PHP|MXN|VND|CZK|HUF|PLN|TRY|ZAR|ILS|ARS|CLP|BRL|RUB|QAR|AED|COP|PEN|CNH|KWD|SAR)\b|
\$[Ub]|
[\p{Sc}ƒ]
"""
test_str = ("Lek\n"
"؋\n"
"$\n"
"ƒ\n"
"$\n"
"₼\n"
"$\n"
"$\n"
"Br\n"
"BZ$\n"
"$\n"
"$b\n"
"KM\n"
"P\n"
"лв\n"
"R$\n"
"$\n"
"៛\n"
"$\n"
"$\n"
"$\n"
"¥\n"
"$\n"
"₡\n"
"kn\n"
"₱\n"
"Kč\n"
"kr\n"
"RD$\n"
"$\n"
"£\n"
"$\n"
"€\n"
"£\n"
"$\n"
"¢\n"
"£\n"
"Q\n"
"£\n"
"$\n"
"L\n"
"$\n"
"Ft\n"
"kr\n\n"
"Rp\n"
"﷼\n"
"£\n"
"₪\n"
"J$\n"
"¥\n"
"£\n"
"лв\n"
"₩\n"
"₩\n"
"лв\n"
"₭\n"
"£\n"
"$\n"
"ден\n"
"RM\n"
"₨\n"
"$\n"
"₮\n"
"MT\n"
"$\n"
"₨\n"
"ƒ\n"
"$\n"
"C$\n"
"₦\n"
"kr\n"
"﷼\n"
"₨\n"
"B/.\n"
"Gs\n"
"S/.\n"
"₱\n"
"zł\n"
"﷼\n"
"lei\n"
"₽\n"
"£\n"
"﷼\n"
"Дин.\n"
"₨\n"
"$\n"
"$\n"
"S\n"
"R\n"
"₨\n"
"kr\n"
"CHF\n"
"$\n"
"£\n"
"NT$\n"
"฿\n"
"TT$\n\n"
"$\n"
"₴\n"
"£\n"
"$\n"
"$U\n"
"лв\n"
"Bs\n"
"₫\n"
"﷼\n"
"Z$\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.