using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[BS]/\.|R(?:D?\$|p))|
\b(?:[TN]T|[CJZ])\$|Дин\.|
\b(?:Bs|Ft|Gs|K[Mč]|Lek|B[Zr]|k[nr]|[PQLSR]|лв|ден|RM|MT|lei|zł|USD|GBP|EUR|JPY|CHF|SEK|DKK|NOK|SGD|HKD|AUD|TWD|NZD|CNY|KRW|INR|CAD|VEF|EGP|THB|IDR|PKR|MYR|PHP|MXN|VND|CZK|HUF|PLN|TRY|ZAR|ILS|ARS|CLP|BRL|RUB|QAR|AED|COP|PEN|CNH|KWD|SAR)\b|
\$[Ub]|
[\p{Sc}ƒ]";
string input = @"Lek
؋
$
ƒ
$
₼
$
$
Br
BZ$
$
$b
KM
P
лв
R$
$
៛
$
$
$
¥
$
₡
kn
₱
Kč
kr
RD$
$
£
$
€
£
$
¢
£
Q
£
$
L
$
Ft
kr
Rp
﷼
£
₪
J$
¥
£
лв
₩
₩
лв
₭
£
$
ден
RM
₨
$
₮
MT
$
₨
ƒ
$
C$
₦
kr
﷼
₨
B/.
Gs
S/.
₱
zł
﷼
lei
₽
£
﷼
Дин.
₨
$
$
S
R
₨
kr
CHF
$
£
NT$
฿
TT$
$
₴
£
$
$U
лв
Bs
₫
﷼
Z$
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}