#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?:[^\d>]+|:[A-Za-z0-9]+:)\w+>"
Local $sString = "<@108012418998792192> (User)" & @CRLF & _
"<@!420279649055145996> (User)" & @CRLF & _
"<:oof:463391326491377674> (Emote without number in name)" & @CRLF & _
"<:Tyler1:311344841466576896> (Emote with number in name)" & @CRLF & _
"<:1234:123412314353463456> (Emote that just has number in name)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")