re = /<(?:[^\d>]+|:[A-Za-z0-9]+:)\w+>/m
str = '<@108012418998792192> (User)
<@!420279649055145996> (User)
<:oof:463391326491377674> (Emote without number in name)
<:Tyler1:311344841466576896> (Emote with number in name)
<:1234:123412314353463456> (Emote that just has number in name)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end