import re
regex = re.compile(r"<(?:[^\d>]+|:[A-Za-z0-9]+:)\w+>", flags=re.MULTILINE)
test_str = ("<@108012418998792192> (User)\n"
"<@!420279649055145996> (User)\n"
"<:oof:463391326491377674> (Emote without number in name)\n"
"<:Tyler1:311344841466576896> (Emote with number in name)\n"
"<:1234:123412314353463456> (Emote that just has number in name)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")