import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:[^\\d>]+|:[A-Za-z0-9]+:)\\w+>";
final String string = "<@108012418998792192> (User)\n"
+ "<@!420279649055145996> (User)\n"
+ "<:oof:463391326491377674> (Emote without number in name)\n"
+ "<:Tyler1:311344841466576896> (Emote with number in name)\n"
+ "<:1234:123412314353463456> (Emote that just has number in name)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}