package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(?:[^\d>]+|:[A-Za-z0-9]+:)\w+>`)
var str = `<@108012418998792192> (User)
<@!420279649055145996> (User)
<:oof:463391326491377674> (Emote without number in name)
<:Tyler1:311344841466576896> (Emote with number in name)
<:1234:123412314353463456> (Emote that just has number in name)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}