using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(first|second|third|fourth)(?=,|\h+(?:and|section)\b)(?=.*\hsection\b)";
string input = @"something first other and then first, second, third and fourth section
dsfsdf first,
fourth section";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}