const regex = /\b(first|second|third|fourth)(?=,|\h+(?:and|section)\b)(?=.*\hsection\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(first|second|third|fourth)(?=,|\\h+(?:and|section)\\b)(?=.*\\hsection\\b)', 'g')
const str = `something first other and then first, second, third and fourth section
dsfsdf first,
fourth section`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}