$re = '/\b(first|second|third|fourth)(?=,|\h+(?:and|section)\b)(?=.*\hsection\b)/';
$str = 'something first other and then first, second, third and fourth section
dsfsdf first,
fourth section';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);