re = /\b(first|second|third|fourth)(?=,|\h+(?:and|section)\b)(?=.*\hsection\b)/
str = 'something first other and then first, second, third and fourth section
dsfsdf first,
fourth section'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end