import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(first|second|third|fourth)(?=,|\\h+(?:and|section)\\b)(?=.*\\hsection\\b)";
final String string = "something first other and then first, second, third and fourth section\n\n"
+ "dsfsdf first,\n\n"
+ "fourth section";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}