import Foundation
let pattern = #"\b(first|second|third|fourth)(?=,|\h+(?:and|section)\b)(?=.*\hsection\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
something first other and then first, second, third and fourth section
dsfsdf first,
fourth section
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)