using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Link:\h*(\S+)\h+Password:\h*(\S+)";
string input = @"Link:https://pan.baidu.com/s/1aKsPhvckPRB2RGheB9KW5g Password:vvbd
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}