re = /Link:\h*(\S+)\h+Password:\h*(\S+)/m
str = 'Link:https://pan.baidu.com/s/1aKsPhvckPRB2RGheB9KW5g Password:vvbd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end