$re = '/Link:\h*(\S+)\h+Password:\h*(\S+)/mu';
$str = 'Link:https://pan.baidu.com/s/1aKsPhvckPRB2RGheB9KW5g Password:vvbd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);