const regex = /HEADLINE(?:(?!HEADLINE)[\s\S])*(?<!NON-)ARC(?:(?!HEADLINE)[\s\S])*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('HEADLINE(?:(?!HEADLINE)[\\s\\S])*(?<!NON-)ARC(?:(?!HEADLINE)[\\s\\S])*', 'gm')
const str = `HEADLINE
Subheader Author
NON-ARC 0.1-1
20190211
HEADLINE
Subheader Author
ARC 0.1-1
20190211
HEADLINE
Subheader Author
NON-ARC 0.1-1
20190211
HEADLINE
Subheader Author
20190211
HEADLINE
Subheader Author
ARC 0.1-1
20190211`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}