import re
regex = re.compile(r"HEADLINE(?:(?!HEADLINE)[\s\S])*(?<!NON-)ARC(?:(?!HEADLINE)[\s\S])*", flags=re.MULTILINE)
test_str = ("HEADLINE\n"
"Subheader Author\n"
"NON-ARC 0.1-1\n"
"20190211\n\n"
"HEADLINE\n"
"Subheader Author\n"
"ARC 0.1-1\n"
"20190211\n\n"
"HEADLINE\n"
"Subheader Author\n"
"NON-ARC 0.1-1\n"
"20190211\n\n"
"HEADLINE\n"
"Subheader Author\n"
"20190211\n\n"
"HEADLINE\n"
"Subheader Author\n"
"ARC 0.1-1\n"
"20190211")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")