import Foundation
let pattern = #"HEADLINE(?:(?!HEADLINE)[\s\S])*(?<!NON-)ARC(?:(?!HEADLINE)[\s\S])*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
HEADLINE
Subheader Author
NON-ARC 0.1-1
20190211
HEADLINE
Subheader Author
ARC 0.1-1
20190211
HEADLINE
Subheader Author
NON-ARC 0.1-1
20190211
HEADLINE
Subheader Author
20190211
HEADLINE
Subheader Author
ARC 0.1-1
20190211
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)