$re = '/HEADLINE(?:(?!HEADLINE)[\s\S])*(?<!NON-)ARC(?:(?!HEADLINE)[\s\S])*/m';
$str = 'HEADLINE
Subheader Author
NON-ARC 0.1-1
20190211
HEADLINE
Subheader Author
ARC 0.1-1
20190211
HEADLINE
Subheader Author
NON-ARC 0.1-1
20190211
HEADLINE
Subheader Author
20190211
HEADLINE
Subheader Author
ARC 0.1-1
20190211';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);