#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<lhs>(?:[\+\-]*)?\d+) *(?<op>[\+\-\*\/\^]) *(?<rhs>(?:[\+\-] *)?\d+)"
Local $sString = "Available operations." & @CRLF & _
"1. 2+3" & @CRLF & _
"2. 2-3" & @CRLF & _
"3. 2*3" & @CRLF & _
"4. 2/3" & @CRLF & _
"5. 2^3" & @CRLF & _
"" & @CRLF & _
"Negative numbers." & @CRLF & _
"6. -2+3" & @CRLF & _
"7. 2+-3" & @CRLF & _
"8. -2+-3" & @CRLF & _
"9. -2--3" & @CRLF & _
"" & @CRLF & _
"Ignores spaces, but not zeroes" & @CRLF & _
"10. 2 + 3 " & @CRLF & _
"11. 15 ^ -1" & @CRLF & _
"12. -00+ 02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")