re = /(?<lhs>(?:[\+\-]*)?\d+) *(?<op>[\+\-\*\/\^]) *(?<rhs>(?:[\+\-] *)?\d+)/m
str = 'Available operations.
1. 2+3
2. 2-3
3. 2*3
4. 2/3
5. 2^3
Negative numbers.
6. -2+3
7. 2+-3
8. -2+-3
9. -2--3
Ignores spaces, but not zeroes
10. 2 + 3
11. 15 ^ -1
12. -00+ 02'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end