const regex = /(?<lhs>(?:[\+\-]*)?\d+) *(?<op>[\+\-\*\/\^]) *(?<rhs>(?:[\+\-] *)?\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<lhs>(?:[\\+\\-]*)?\\d+) *(?<op>[\\+\\-\\*\\\/\\^]) *(?<rhs>(?:[\\+\\-] *)?\\d+)', 'gm')
const str = `Available operations.
1. 2+3
2. 2-3
3. 2*3
4. 2/3
5. 2^3
Negative numbers.
6. -2+3
7. 2+-3
8. -2+-3
9. -2--3
Ignores spaces, but not zeroes
10. 2 + 3
11. 15 ^ -1
12. -00+ 02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}