import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<lhs>(?:[\\+\\-]*)?\\d+) *(?<op>[\\+\\-\\*\\/\\^]) *(?<rhs>(?:[\\+\\-] *)?\\d+)";
final String string = "Available operations.\n"
+ "1. 2+3\n"
+ "2. 2-3\n"
+ "3. 2*3\n"
+ "4. 2/3\n"
+ "5. 2^3\n\n"
+ "Negative numbers.\n"
+ "6. -2+3\n"
+ "7. 2+-3\n"
+ "8. -2+-3\n"
+ "9. -2--3\n\n"
+ "Ignores spaces, but not zeroes\n"
+ "10. 2 + 3 \n"
+ "11. 15 ^ -1\n"
+ "12. -00+ 02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}