# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(?:https?:\\/\\/)?(?:(?:(?!example)\w+[.-])+[a-z]{2,11})(?!\S)/[URl Hidden]/gi;t' <<< "name.url.com name-dev.url.com name-qa.url.com www.example.com test.example.com http://NewMediaFilmFestival.com http://www.test.com https://www.example.com jfsalkjflkdjfa.vuulr.com
jfsalkjflkdjfa.com
"