use strict;
my $str = 'name.url.com name-dev.url.com name-qa.url.com www.example.com test.example.com http://NewMediaFilmFestival.com http://www.test.com https://www.example.com jfsalkjflkdjfa.vuulr.com
jfsalkjflkdjfa.com
';
my $regex = qr/(?<!\S)(?:https?:\/\/)?(?:(?:(?!example)\w+[.-])+[a-z]{2,11})(?!\S)/ip;
my $subst = '[URl Hidden]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";