re = /(?<!\S)(?:https?:\/\/)?(?:(?:(?!example)\w+[.-])+[a-z]{2,11})(?!\S)/i
str = 'name.url.com name-dev.url.com name-qa.url.com www.example.com test.example.com http://NewMediaFilmFestival.com http://www.test.com https://www.example.com jfsalkjflkdjfa.vuulr.com
jfsalkjflkdjfa.com
'
subst = '[URl Hidden]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result