import re
regex = re.compile(r"(?<!\S)(?:https?:\/\/)?(?:(?:(?!example)\w+[.-])+[a-z]{2,11})(?!\S)", flags=re.IGNORECASE)
test_str = ("name.url.com name-dev.url.com name-qa.url.com www.example.com test.example.com http://NewMediaFilmFestival.com http://www.test.com https://www.example.com jfsalkjflkdjfa.vuulr.com\n"
"jfsalkjflkdjfa.com\n")
subst = "[URl Hidden]"
result = regex.sub(subst, test_str)
if result:
print(result)