using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:https?:\/\/)?(?:(?:(?!example)\w+[.-])+[a-z]{2,11})(?!\S)";
string substitution = @"[URl Hidden]";
string input = @"name.url.com name-dev.url.com name-qa.url.com www.example.com test.example.com http://NewMediaFilmFestival.com http://www.test.com https://www.example.com jfsalkjflkdjfa.vuulr.com
jfsalkjflkdjfa.com
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}