#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-[^-]+(jpg|webp)$"
Local $sString = "name1-20-pencvjdvlbfkgbfkgfgjkf.jpg" & @CRLF & _
"name3-120-pencvjdvlbfkgbfkgfggrgrgrjkf.jpg" & @CRLF & _
"name4-dfdfdfd-pencvjdvlbfkgbfkgfgjkf.webp" & @CRLF & _
"name5-2adsd0-wwdencvjdvlbfkgbfkgfgjkf.jpg" & @CRLF & _
"name6-2dd-rtywdencvjdvlbfkgbfkgfgjkf.jpg" & @CRLF & _
"name7-hhdd-vvvtywdencvjdvlbfkgbfkgfgjkf.webp" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)