package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-[^-]+(jpg|webp)$`)
var str = `name1-20-pencvjdvlbfkgbfkgfgjkf.jpg
name3-120-pencvjdvlbfkgbfkgfggrgrgrjkf.jpg
name4-dfdfdfd-pencvjdvlbfkgbfkgfgjkf.webp
name5-2adsd0-wwdencvjdvlbfkgbfkgfgjkf.jpg
name6-2dd-rtywdencvjdvlbfkgbfkgfgjkf.jpg
name7-hhdd-vvvtywdencvjdvlbfkgbfkgfgjkf.webp
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}