use strict;
my $str = 'name1-20-pencvjdvlbfkgbfkgfgjkf.jpg
name3-120-pencvjdvlbfkgbfkgfggrgrgrjkf.jpg
name4-dfdfdfd-pencvjdvlbfkgbfkgfgjkf.webp
name5-2adsd0-wwdencvjdvlbfkgbfkgfgjkf.jpg
name6-2dd-rtywdencvjdvlbfkgbfkgfgjkf.jpg
name7-hhdd-vvvtywdencvjdvlbfkgbfkgfgjkf.webp
';
my $regex = qr/-[^-]+(jpg|webp)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";