// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-[^-]+(jpg|webp)$").unwrap();
let string = "name1-20-pencvjdvlbfkgbfkgfgjkf.jpg
name3-120-pencvjdvlbfkgbfkgfggrgrgrjkf.jpg
name4-dfdfdfd-pencvjdvlbfkgbfkgfgjkf.webp
name5-2adsd0-wwdencvjdvlbfkgbfkgfgjkf.jpg
name6-2dd-rtywdencvjdvlbfkgbfkgfgjkf.jpg
name7-hhdd-vvvtywdencvjdvlbfkgbfkgfgjkf.webp
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}