import Foundation
let pattern = #"-[^-]+(jpg|webp)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
name1-20-pencvjdvlbfkgbfkgfgjkf.jpg
name3-120-pencvjdvlbfkgbfkgfggrgrgrjkf.jpg
name4-dfdfdfd-pencvjdvlbfkgbfkgfgjkf.webp
name5-2adsd0-wwdencvjdvlbfkgbfkgfgjkf.jpg
name6-2dd-rtywdencvjdvlbfkgbfkgfgjkf.jpg
name7-hhdd-vvvtywdencvjdvlbfkgbfkgfgjkf.webp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)