import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-[^-]+(jpg|webp)$";
final String string = "name1-20-pencvjdvlbfkgbfkgfgjkf.jpg\n"
+ "name3-120-pencvjdvlbfkgbfkgfggrgrgrjkf.jpg\n"
+ "name4-dfdfdfd-pencvjdvlbfkgbfkgfgjkf.webp\n"
+ "name5-2adsd0-wwdencvjdvlbfkgbfkgfgjkf.jpg\n"
+ "name6-2dd-rtywdencvjdvlbfkgbfkgfgjkf.jpg\n"
+ "name7-hhdd-vvvtywdencvjdvlbfkgbfkgfgjkf.webp\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}