# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({ads\.prime\("mid_leaderboard_rectangle_)\d+("\)})/\1%d\2/gm;t' <<< "Some Text1adCommands.push(function(ads){ads.prime(\"mid_leaderboard_rectangle_9\")});Some Text2adCommands.push(function(ads){ads.prime(\"mid_leaderboard_rectangle_10\")});Some Text3adCommands.push(function(ads){ads.prime(\"mid_leaderboard_rectangle_11\")});Some Text4
"