# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'({ads\.prime\("mid_leaderboard_rectangle_)\d+("\)})'
test_str = ("Some Text1adCommands.push(function(ads){ads.prime(\"mid_leaderboard_rectangle_9\")});Some Text2adCommands.push(function(ads){ads.prime(\"mid_leaderboard_rectangle_10\")});Some Text3adCommands.push(function(ads){ads.prime(\"mid_leaderboard_rectangle_11\")});Some Text4\n")
subst = "\\1%d\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.