package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)({ads\.prime\("mid_leaderboard_rectangle_)\d+("\)})`)
var str = `Some Text1adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_9")});Some Text2adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_10")});Some Text3adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_11")});Some Text4
`
var substitution = "\1%d\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}