use strict;
my $str = 'Some Text1adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_9")});Some Text2adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_10")});Some Text3adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_11")});Some Text4
';
my $regex = qr/({ads\.prime\("mid_leaderboard_rectangle_)\d+("\)})/mp;
my $subst = '\\1%d\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";