using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({ads\.prime\(""mid_leaderboard_rectangle_)\d+(""\)})";
string substitution = @"\1%d\2";
string input = @"Some Text1adCommands.push(function(ads){ads.prime(""mid_leaderboard_rectangle_9"")});Some Text2adCommands.push(function(ads){ads.prime(""mid_leaderboard_rectangle_10"")});Some Text3adCommands.push(function(ads){ads.prime(""mid_leaderboard_rectangle_11"")});Some Text4
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}