re = /({ads\.prime\("mid_leaderboard_rectangle_)\d+("\)})/m
str = 'Some Text1adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_9")});Some Text2adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_10")});Some Text3adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_11")});Some Text4
'
subst = '\\1%d\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result