#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:i\s)?(?:have\s)?(?<!had\s)(?:the\s)?same\s(?:(?:problem|question|issue)|here))"
Local $sString = "having the same issue" & @CRLF & _
"facing the same problem" & @CRLF & _
"have the same question" & @CRLF & _
"I am getting the same issue" & @CRLF & _
"I see the same issue" & @CRLF & _
"I have same issue" & @CRLF & _
"" & @CRLF & _
"I had the same issue" & @CRLF & _
"have had the same question" & @CRLF & _
"I faced the same issue"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")