using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:i\s)?(?:have\s)?(?<!had\s)(?:the\s)?same\s(?:(?:problem|question|issue)|here))";
string input = @"having the same issue
facing the same problem
have the same question
I am getting the same issue
I see the same issue
I have same issue
I had the same issue
have had the same question
I faced the same issue";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}