import re
regex = re.compile(r"((?:i\s)?(?:have\s)?(?<!had\s)(?:the\s)?same\s(?:(?:problem|question|issue)|here))", flags=re.MULTILINE)
test_str = ("having the same issue\n"
"facing the same problem\n"
"have the same question\n"
"I am getting the same issue\n"
"I see the same issue\n"
"I have same issue\n\n"
"I had the same issue\n"
"have had the same question\n"
"I faced the same issue")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")