const regex = /((?:i\s)?(?:have\s)?(?<!had\s)(?:the\s)?same\s(?:(?:problem|question|issue)|here))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:i\\s)?(?:have\\s)?(?<!had\\s)(?:the\\s)?same\\s(?:(?:problem|question|issue)|here))', 'gm')
const str = `having the same issue
facing the same problem
have the same question
I am getting the same issue
I see the same issue
I have same issue
I had the same issue
have had the same question
I faced the same issue`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}