re = /((?:i\s)?(?:have\s)?(?<!had\s)(?:the\s)?same\s(?:(?:problem|question|issue)|here))/m
str = 'having the same issue
facing the same problem
have the same question
I am getting the same issue
I see the same issue
I have same issue
I had the same issue
have had the same question
I faced the same issue'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end