import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:i\\s)?(?:have\\s)?(?<!had\\s)(?:the\\s)?same\\s(?:(?:problem|question|issue)|here))";
final String string = "having the same issue\n"
+ "facing the same problem\n"
+ "have the same question\n"
+ "I am getting the same issue\n"
+ "I see the same issue\n"
+ "I have same issue\n\n"
+ "I had the same issue\n"
+ "have had the same question\n"
+ "I faced the same issue";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}