using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=2020)\d{2}";
string input = @"Diagnostics 20200826-12345moretext.zip
Diagnostics 20205839-12345moretext.zip
Diagnostics 20209999-12345moretext.zip
//doesnt start with 2020
Diagnostics 20001212-12345moretext.zip";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}