import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=2020)\\d{2}";
final String string = "Diagnostics 20200826-12345moretext.zip\n\n"
+ "Diagnostics 20205839-12345moretext.zip\n\n"
+ "Diagnostics 20209999-12345moretext.zip\n\n"
+ "//doesnt start with 2020\n"
+ "Diagnostics 20001212-12345moretext.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}